Nouveau sujet Répondre Imprimer Syndication RSS 2.0

Souci IP Failover

apache pas content :(
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 27 Septembre 2009, 19:24
Bonsoir,


J'ai ajouté le ip failover disponible gracieusement avec nos kimsufi sur mon serveur.
Il me semble avoir fait cela correctement, cependant j'ai un petit souci avec apache lors de l'ajout de nom de domaine sur l'ip principal, je n'ai pas testé sur une ip secondaire ayant eu directement le souci suivant :


ksxxxxxx:/# /etc/init.d/apache2 reload
Reloading web server config: apache2[Sun Sep 27 03:14:41 2009] [warn] VirtualHost 94.xx.xxx.xx:80 overlaps with VirtualHost 94.xx.xxx.xx:80, the first has precedence, perhaps you need a NameVirtualHost directive


Le fichier de conf apache correspondant à mon site :

<VirtualHost 94.xx.xxx.xx:80>
        ServerAdmin admin@sitebis.tv
        ServerName www.sitebis.tv
        ServerAlias 
        DocumentRoot /home/users/sitebis.tv/www


        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/users/sitebis.tv/www>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


J'ai donc ajouté une directive NameVirtualHost mais j'ai ceci :


ksxxxxxx:/etc/apache2/sites-available# /etc/init.d/apache2 reload
Reloading web server config: apache2[Sun Sep 27 03:17:25 2009] [error] VirtualHost 94.xx.xxx.xx:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Sun Sep 27 03:17:25 2009] [error] VirtualHost 94.xx.xxx.xx:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results


Avec cela comme fichier :
NameVirtualhost 94.xx.xxx.xx

<VirtualHost 94.xx.xxx.xx:80>
        ServerAdmin admin@sitebis.tv
        ServerName www.sitebis.tv
        ServerAlias 
        DocumentRoot /home/users/sitebis.tv/www


        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/users/sitebis.tv/www>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>





Quelle est mon erreur...?


Merci



PS: j'ai posté chez kimsufi aussi car ça m'ennuie de vous embeter avec tout ça, donc si ça permet de vous alléger un peu avec mes ennuis :ok:
 
Manchot de magellan
Avatar de lili
  • Age : 59 ans
  • Messages : 1343
  • Inscrit : 26 Novembre 2007
  • OS : Ubuntu
  • Interface : Gnome
  • Navigateur : Firefox
  • Courrielleur : Thunderbird
  • Messagerie : Amsn
  Lien vers ce message 28 Septembre 2009, 0:21
mais faut pas te biler pour ça, ils adooooorent ! Pis, jusqu'à présent, c'était mon coin la salle des galères, mais je veux bien la partager moi, tu penses ! C'est mon côté altruiste et généreux !
:D :D :D


bon, ben finalement, rien ne sert de mourir, autant courir heu... non ! sourire, à point !
Y a pire : rien ne sert de croupir, il faut pourrir à point... Mais je la trouve un peu maussade... Pas vous ?
 
Manchot antipode
Avatar de The Worm's
  • Age : 38 ans
  • Messages : 2682
  • Inscrit : 26 Novembre 2007
  • OS : Arch Linux
  • Interface : Gnome
  • Navigateur : Firefox
  • Courrielleur : Thunderbird
  • Messagerie : Gajim
  Lien vers ce message 28 Septembre 2009, 0:36
Enlève la ligne "Name VirtualHost"

Et oui ont attends que ça de t'aider sinon si tu étais venues sans soucis, c'est pas drole :ptdr:

Pour ça que dès que tu t'inscris sur le forum, un spyware s'incruste dans ton système d'exploitation pour le faire bugger. Et pour ton serveur vu que je me suis connecté dessus j'ai fais de même...

arf j'ai dévoilé le secret :diable:
 
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 28 Septembre 2009, 0:42
Merci de partager lili ;)


Pour NameVirtualHost je n'en avais pas à la base mais j'avais ce message
Reloading web server config: apache2[Mon Sep 28 00:39:20 2009] [warn] VirtualHost 94.xx.xxx.xx:80 overlaps with VirtualHost 94.xx.xxx.xx:80, the first has precedence, perhaps you need a NameVirtualHost directive



Donc je l'ai ajouté...
 
Manchot antipode
Avatar de The Worm's
  • Age : 38 ans
  • Messages : 2682
  • Inscrit : 26 Novembre 2007
  • OS : Arch Linux
  • Interface : Gnome
  • Navigateur : Firefox
  • Courrielleur : Thunderbird
  • Messagerie : Gajim
  Lien vers ce message 28 Septembre 2009, 1:00
Ah vi pas tout lu :)

Ne met pas l'ip dans le nom de ton hote mais véritablement le nom de l'hôte ;)
 
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 28 Septembre 2009, 1:07
hheeuu... comment ça? :O

Comment je vais faire pour utiliser l'ip failover ensuite?
 
Manchot antipode
Avatar de The Worm's
  • Age : 38 ans
  • Messages : 2682
  • Inscrit : 26 Novembre 2007
  • OS : Arch Linux
  • Interface : Gnome
  • Navigateur : Firefox
  • Courrielleur : Thunderbird
  • Messagerie : Gajim
  Lien vers ce message 28 Septembre 2009, 1:22
là tu met ton nom de domaine virtuel : NameVirtualhost MonDomaine

Et là ton ip failover : <VirtualHost 95.xx.xxx.xx:80>
 
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 28 Septembre 2009, 1:30
ah... suis beta parfois...

Je teste!


Edit : ça marche pô.. :(


ksxxxxxx:/etc/apache2/sites-available# /etc/init.d/apache2 reload
Reloading web server config: apache2[Mon Sep 28 01:30:23 2009] [error] VirtualHost 94.XX.XXX.XX:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Mon Sep 28 01:30:23 2009] [error] VirtualHost 94.XX.XXX.XX:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
 
Manchot antipode
Avatar de The Worm's
  • Age : 38 ans
  • Messages : 2682
  • Inscrit : 26 Novembre 2007
  • OS : Arch Linux
  • Interface : Gnome
  • Navigateur : Firefox
  • Courrielleur : Thunderbird
  • Messagerie : Gajim
  Lien vers ce message 28 Septembre 2009, 1:42
OKi je regarderais et si j'ai un peu plus de temps je ferais un tuto ipfailover ;)
 
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 28 Septembre 2009, 1:45
Merci The Worm's!! :D
 
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 01 Octobre 2009, 17:25
Je reviens un peu car il y a certains choses que je ne comprends pas trop...

J'ai essayé de pinguer mes ips = raté.
Je l'ai ai simplement mis dans le navigateur = erreur 400 , bad request.

Même l'ip de base... or je devrais avoir la page par defaut "It Works" enfin, celle mise par The Worms maintenant ^^

Donc je ne saisis pas le pourquoi de otut cela...

De plus pour gérer les sites, je dois tout mettre dans le 000-default, donc un fichier commun, ou autre chose...?

Merci :)
 
Répondre


Sauf mention contraire, le site est placé sous double licence Creative Commons BY-SA et GNU Free Documentation License
.