Nouveau sujet Répondre Imprimer Syndication RSS 2.0

Souci mod Rewrite

Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 28 Septembre 2009, 16:12
Hello! C'est encore moi! Je tiens compagnie à Lili dans ce forum :p


Bon, il semblerait que j'ai un petit souci avec le mod rewrite...

Afin de savoir s'il était actif j'ai essayé cela (trouvé sur un forum via notre ami google) :

Citation ("dcz")
Le plus simple, c'est encore d'essayer :

Pour voir rapidement, crées un ficher trouve.html avec un peut de contenu, n'importe lequel, et upload le à la racine de ton domaine.

Ensuite upload un .htaccess avec :

RewriteEngine On
RewriteBase /
RewriteRule ^cherche\.html$ trouve.html [QSA,L] 


Et essai de charger -www.tondomaine.com/cherche.html, si même avec :

RewriteEngine On
RewriteBase /
RewriteRule ^cherche\.html$ /trouve.html [QSA,L] 


tu ne vois pas le contenu de trouve.html, c'est qu'il y a de très fortes chances que tu ne puisses pas faire de réécriture d'url sur ton serveur.

;)



Et ça ne fonctionne pas, trouve.html est ok, mais cherche.html me donne une 404 donc le rewrite ne fonctionne pas.

J'ai essayé en ajoutant les lignes que m'avais dites The Worms sur mon sujet (mod security etc) , soit :

Citation
décommente (enlever le #) la ligne LoadModule rewrite_module modules/mod_rewrite.so

Fait la même chose pour la ligne AddModule mod_rewrite.c


J'ai donc ajouté ces lignes dans le httpd.conf qui était vide au passage, mais lorsque je relance apache il me dit que c'est pas bon, que les modules rewrite sont déjà chargés.

/etc/apache2# /etc/init.d/apache2 restart
Restarting web server: apache2We failed to correctly shutdown apache, so we're n                        ow killing all running apache processes. This is almost certainly suboptimal, so                         please make sure your system is working as you'd expect now! (warning).
 ... waiting [Mon Sep 28 15:59:14 2009] [warn] module rewrite_module is already                         loaded, skipping
Syntax error on line 35 of /etc/apache2/httpd.conf:
Invalid command 'AddModule', perhaps misspelled or defined by a module not inclu                        ded in the server configuration
 failed!



Que dois je faire pour l'activer?


Merci !
 
Manchot de magellan
Avatar de lili
  • Age : 59 ans
  • Messages : 1343
  • Inscrit : 26 Novembre 2007
  • OS : Ubuntu
  • Interface : Gnome
  • Navigateur : Firefox
  • Courrielleur : Thunderbird
  • Messagerie : Amsn
  Lien vers ce message 28 Septembre 2009, 16:28
mais tu sais qu'ils s'ennuient quand on leur tient pas compagnie ? Tandis que là, ils redeviennent joueurs, le poil soyeux, tout quoi !


bon, ben finalement, rien ne sert de mourir, autant courir heu... non ! sourire, à point !
Y a pire : rien ne sert de croupir, il faut pourrir à point... Mais je la trouve un peu maussade... Pas vous ?
 
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 28 Septembre 2009, 17:52
lol, avec nous ils ont de quoi s'occuper! :D Ce n'est même plus briller là...
 
Manchot adélie
Avatar de clochette
  • Age : 42 ans
  • Messages : 1294
  • Inscrit : 27 Novembre 2007
  • OS : Debian
  • Interface : Gnome
  • Navigateur : Iceweasel
  • Courrielleur : Evolution
  • Messagerie : --
  Lien vers ce message 28 Septembre 2009, 20:09
J'aurai tendance à dire qu'ils étaient déjà chargé les modules donc le souci ne se pose pas au même endroit tout simplement, je penche pour un problème d'accès ou quelque chose dans ce gouts après pour ce type de dépannage je préfère laisser The Worms gérer il est bien pus au jus que moi sur le montage.


Debianneux cornu; Barbu, bouffeur de c... !!
Laptop--RIP
Serveur--PFsense-2.1 && Serveur--FreeNAS-9.1.1
Serveur--Openstack-admin-2012 && Serveur--Openstack-noeud1-2012 && Serveur--Openstack-noeud2-2012
VPS--FreeBSD-9.2
 
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 28 Septembre 2009, 21:28
bon bah on va attendre le chef!
 
Manchot antipode
Avatar de The Worm's
  • Age : 38 ans
  • Messages : 2682
  • Inscrit : 26 Novembre 2007
  • OS : Arch Linux
  • Interface : Gnome
  • Navigateur : Firefox
  • Courrielleur : Thunderbird
  • Messagerie : Gajim
  Lien vers ce message 29 Septembre 2009, 0:45
Et bien tout fonctionne :)

Juste ta config rewrite qui n'est pas bonne ;)
RewriteEngine on
RewriteRule ^cherche\.html$ /trouve.html [L]


En même temps j'ai corrigé plusieurs bugs ;)

D'une part mon erreur vu que j'ai encore un peu de mal à me faire à apache2 ( enfin plus depuis hier à vrai dire ) ;)
 
Manchot adélie
Avatar de clochette
  • Age : 42 ans
  • Messages : 1294
  • Inscrit : 27 Novembre 2007
  • OS : Debian
  • Interface : Gnome
  • Navigateur : Iceweasel
  • Courrielleur : Evolution
  • Messagerie : --
  Lien vers ce message 29 Septembre 2009, 0:52
Ah ouhais ça touche le soir ;p


Debianneux cornu; Barbu, bouffeur de c... !!
Laptop--RIP
Serveur--PFsense-2.1 && Serveur--FreeNAS-9.1.1
Serveur--Openstack-admin-2012 && Serveur--Openstack-noeud1-2012 && Serveur--Openstack-noeud2-2012
VPS--FreeBSD-9.2
 
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 29 Septembre 2009, 1:24
Il est partout... t'as des doubles?

Merci en tout cas c'est super, si t'as le temps de me faire un rapide listing de mes erreurs, des bugs ou autres histoire que j'apprenne, ce serait parfait :)
 
Manchot antipode
Avatar de The Worm's
  • Age : 38 ans
  • Messages : 2682
  • Inscrit : 26 Novembre 2007
  • OS : Arch Linux
  • Interface : Gnome
  • Navigateur : Firefox
  • Courrielleur : Thunderbird
  • Messagerie : Gajim
  Lien vers ce message 29 Septembre 2009, 10:50
Voici ton fichier defaut de apache :
<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride all
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

#       ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
#       <Directory "/usr/lib/cgi-bin">
#               AllowOverride None
#               Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
#               Order allow,deny
#               Allow from all
#       </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

NameVirtualHost TonIP:80

<VirtualHost TonIP:80>
        ServerAdmin webmaster@localhost
        ServerName www.site1.biz
        ServerAlias site1.biz

        DocumentRoot /home/site1
        <Directory /home/site1/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride all
                Order allow,deny
                allow from all
        </Directory>
</VirtualHost>

<VirtualHost TonIP:80>
        ServerAdmin admin@site2.biz
        ServerName www.site2.biz
        ServerAlias site2.biz

        DocumentRoot /home/site2/

        <Directory /home/site2/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride all
                Order allow,deny
                allow from all
        </Directory>
</VirtualHost>
 
Mergule nain
Avatar de Selda
  • Age : 34 ans
  • Messages : 233
  • Inscrit : 21 Aout 2009
  • OS : --
  • Interface : --
  • Navigateur : --
  • Courrielleur : --
  • Messagerie : --
  Lien vers ce message 29 Septembre 2009, 15:27
Donc en fait, tout doit passer par le fichier default, et non créer d'autre fichier de conf...?
 
Répondre


Sauf mention contraire, le site est placé sous double licence Creative Commons BY-SA et GNU Free Documentation License
.